Made sources and debian package buildable on current versions of software.
[gedcom-parse.git] / debian / rules
index e8f37917ebb77ee86a856a23404cecd363a6f9a6..65712a4e1570a031e5bb32fd879cf8c537e0be5a 100755 (executable)
@@ -2,49 +2,14 @@
 # Made with the aid of debmake, by Christoph Lameter,
 # based on the sample debian/rules file for GNU hello by Ian Jackson.
 
-package=gedcom-parse-dev
+#package=gedcom-parse-dev
 
-build:
-       $(checkdir)
-       ./configure --prefix=/usr
-       $(MAKE) CFLAGS="-O2 -g -Wall"
-       touch build
+%:
+       dh $@ --with autotools-dev --with autoreconf
 
-clean:
-       $(checkdir)
-       rm -f build
-       -$(MAKE) distclean
-       rm -f `find . -name "*~"`
-       rm -rf debian/tmp debian/files* core debian/substvars
+override_dh_auto_configure:
+       dh_auto_configure --  --prefix=/usr
 
-binary-indep: checkroot build
-       $(checkdir)
-# There are no architecture-independent files to be uploaded
-# generated by this package.  If there were any they would be
-# made here.
-
-binary-arch: checkroot build
-       $(checkdir)
-       rm -rf debian/tmp
-       install -d debian/tmp
-       cd debian/tmp && install -d `cat ../dirs`
-       $(MAKE) install prefix=`pwd`/debian/tmp/usr
-# Must have debmake installed for this to work. Otherwise please copy
-# /usr/bin/debstd into the debian directory and change debstd to debian/debstd
-       debstd ChangeLog NEWS README TODO 
-       dpkg-gencontrol -isp
-       chown -R root:root debian/tmp
-       chmod -R go=rX debian/tmp
-       dpkg --build debian/tmp ..
-
-define checkdir
-       test -f debian/rules
-endef
-
-binary: binary-indep binary-arch
-
-checkroot:
-       $(checkdir)
-       test root = "`whoami`"
-
-.PHONY: binary binary-arch binary-indep clean checkroot
+override_dh_auto_build:
+       automake
+       dh_auto_build