Add Required tests.
[command.git] / tests / Makefile.am
index 11c3c1800278de23e0a90b806be2c9374ba6770f..6a0fa06e817a8d3e019ca9bb6d09de7217ad2c7c 100644 (file)
@@ -19,7 +19,8 @@ TESTS = \
        option_handles_boolean_value.test \
        option_handles_void_value.test \
        option_should_match_exact_name.test \
-       option_should_throw_exception_on_missing_value.test
+       option_should_throw_exception_on_missing_value.test \
+       required_should_be_required.test
 
 noinst_PROGRAMS = $(TESTS)
 
@@ -48,3 +49,5 @@ option_handles_boolean_value_test_SOURCES  = option/handles_boolean_value.cpp
 option_handles_void_value_test_SOURCES  = option/handles_void_value.cpp
 option_should_match_exact_name_test_SOURCES  = option/should_match_exact_name.cpp
 option_should_throw_exception_on_missing_value_test_SOURCES = option/should_throw_exception_on_missing_value.cpp
+
+required_should_be_required_test_SOURCES = required/should_be_required.cpp