Add Argument tests.
[command.git] / tests / Makefile.am
index e69de29bb2d1d6434b8b29ae775ad8c2e48c5391..b60d58a44f5824db81ffd3ba4d2523cd1cec2b8a 100644 (file)
@@ -0,0 +1,16 @@
+AUTOMAKE_OPTIONS = subdir-objects
+
+TESTS = \
+       descriptive_holds_data.test \
+       callable_invokes_provided_function.test \
+       parameter_is_descriptive.test \
+       argument_handles_string_value.test
+
+noinst_PROGRAMS = $(TESTS)
+
+AM_CXXFLAGS = -O3 -I$(top_srcdir)/include -std=c++11
+
+descriptive_holds_data_test_SOURCES  = descriptive/holds_data.cpp
+callable_invokes_provided_function_test_SOURCES  = callable/invokes_provided_function.cpp
+parameter_is_descriptive_test_SOURCES  = parameter/is_descriptive.cpp
+argument_handles_string_value_test_SOURCES  = argument/handles_string_value.cpp