Add Possibility to set MultiValue Parameters.
[command.git] / tests / Makefile.am
index 224aa6aabb2684d1cd26b0c293ec45fc8ec182c0..d7b072a9b6a377bcc11e07a3af707c01f85b733c 100644 (file)
@@ -5,6 +5,7 @@ TESTS = \
        callable_invokes_provided_function.test \
        callable_invokes_void_function.test \
        parameter_is_descriptive.test \
+       parameter_should_be_non_required.test \
        argument_handles_string_value.test \
        argument_handles_int_value.test \
        argument_handles_negative_int_value.test \
@@ -12,12 +13,20 @@ TESTS = \
        argument_handles_negative_float_value.test \
        argument_handles_boolean_value.test \
        option_handles_string_value.test \
+       option_handles_int_value.test \
+       option_handles_negative_int_value.test \
+       option_handles_float_value.test \
+       option_handles_negative_float_value.test \
        option_handles_boolean_value.test \
-       option_handles_float_value.test
+       option_handles_void_value.test \
+       option_should_match_exact_name.test \
+       option_should_throw_exception_on_missing_value.test \
+       required_should_be_required.test \
+       multivalue_should_extract_values_by_separator.test
 
 noinst_PROGRAMS = $(TESTS)
 
-AM_CXXFLAGS = -O3 -I$(top_srcdir)/include -std=c++11
+AM_CXXFLAGS = -I$(top_srcdir)/include -std=c++11
 
 descriptive_holds_data_test_SOURCES  = descriptive/holds_data.cpp
 
@@ -25,6 +34,7 @@ callable_invokes_provided_function_test_SOURCES  = callable/invokes_provided_fun
 callable_invokes_void_function_test_SOURCES  = callable/invokes_void_function.cpp
 
 parameter_is_descriptive_test_SOURCES  = parameter/is_descriptive.cpp
+parameter_should_be_non_required_test_SOURCES = parameter/should_be_non_required.cpp
 
 argument_handles_string_value_test_SOURCES  = argument/handles_string_value.cpp
 argument_handles_int_value_test_SOURCES  = argument/handles_int_value.cpp
@@ -34,5 +44,15 @@ argument_handles_negative_float_value_test_SOURCES  = argument/handles_negative_
 argument_handles_boolean_value_test_SOURCES  = argument/handles_boolean_value.cpp
 
 option_handles_string_value_test_SOURCES  = option/handles_string_value.cpp
-option_handles_boolean_value_test_SOURCES  = option/handles_boolean_value.cpp
+option_handles_int_value_test_SOURCES = option/handles_int_value.cpp
+option_handles_negative_int_value_test_SOURCES = option/handles_negative_int_value.cpp
 option_handles_float_value_test_SOURCES  = option/handles_float_value.cpp
+option_handles_negative_float_value_test_SOURCES  = option/handles_negative_float_value.cpp
+option_handles_boolean_value_test_SOURCES  = option/handles_boolean_value.cpp
+option_handles_void_value_test_SOURCES  = option/handles_void_value.cpp
+option_should_match_exact_name_test_SOURCES  = option/should_match_exact_name.cpp
+option_should_throw_exception_on_missing_value_test_SOURCES = option/should_throw_exception_on_missing_value.cpp
+
+required_should_be_required_test_SOURCES = required/should_be_required.cpp
+
+multivalue_should_extract_values_by_separator_test_SOURCES = multiValue/should_extract_values_by_separator.cpp