Fix building and installing package.
[genetic.git] / include / Makefile.am
diff --git a/include/Makefile.am b/include/Makefile.am
new file mode 100644 (file)
index 0000000..2938285
--- /dev/null
@@ -0,0 +1,17 @@
+nobase_pkginclude_HEADERS = \
+    gene.h \
+    chromosome.h \
+    generation.h \
+    algorithm.h \
+    condition/condition.h \
+    condition/generationLimitCondition.h \
+    crossover/crossover.h \
+    fitness/fitness.h \
+    fitness/wsti.h \
+    fitness/example.h \
+    generator/generator.h \
+    generator/bitGenerator.h \
+    mutation/mutation.h \
+    selection/selection.h \
+    selection/rouletteSelection.h \
+    selection/linearRankSelection.h