Add BitGenerator tests. Restructure tests.
[genetic.git] / tests / Makefile.am
index b869300203e8ee10d297492d50bb964acaff4822..6dcf89a1a729fc9075cc72b8048320477c974515 100644 (file)
@@ -1,7 +1,30 @@
-SUBDIRS = \
-       gene \
-       chromosome \
-       generation
+AUTOMAKE_OPTIONS = subdir-objects
+
+TESTS = \
+       gene_create.test \
+       gene_copy.test \
+       chromosome_create.test\
+       chromosome_copy.test \
+       generation_create.test\
+       generation_copy.test \
+       generator_bitGeneratorBreed.test
+
+noinst_PROGRAMS = $(TESTS)
+
+AM_CPPFLAGS   = -O2 -I$(top_srcdir)/src
+
+gene_create_test_SOURCES  = gene/create.cpp
+gene_copy_test_SOURCES  = gene/copy.cpp
+
+chromosome_create_test_SOURCES  = chromosome/create.cpp
+chromosome_copy_test_SOURCES  = chromosome/copy.cpp
+
+generation_create_test_SOURCES  = generation/create.cpp
+generation_copy_test_SOURCES  = generation/copy.cpp
+
+generator_bitGeneratorBreed_test_SOURCES  = generator/bitGenerator/breed.cpp
 
 clean-local:
-       rm -f *.log
\ No newline at end of file
+       rm -f *.log
+
+all-local:
\ No newline at end of file